• BronwellBronwell March 2014
    Posts: 14
    Good day.

    I have setup my pond and running for 2 months now.

    The water that comes out of the bio filter outlet is dirty and has worms and poo if I trap some of the water. Is this normal?I am also running a sand filter and a skimmer in my 5000l pond.

    Is the dirty water coming out of the bio filter normal? I also have a blue filter mat and lots of bio balls in the filter.
  • HDCuHDCu March 2014
    Posts: 1,117
    No its not normal. How often do you clean your filters?
  • BronwellBronwell March 2014
    Posts: 14
    I clean d sand filter daily and backwash every 3 days. The bio filters I do not clean, only running 2 months, should I clean them?
  • jaysonjayson March 2014
    Posts: 106
    Bro Bronwell, I think you need to show us how your filter setup and how the piping connect.
    :)
  • BronwellBronwell March 2014
    Posts: 14
    Hi Jayson, here are pics of the bio filter, the outlet seems clean this morning, none of the stuff I described yesterday. What I did do was put a piece of filter mat ( blue ) at the inlet of the filter, thereafter the water passes through the bio balls. For some reason I cannot upload pics from my iPad
  • HDCuHDCu March 2014
    Posts: 1,117
    Bro Bromwell,

    I am unsure of your filtration setup but you have to distinguish what is your mechanical filter media, biological filter media and finally your polishing media.
    Bio filters are not meants to trap waste, it is the job the mechanical filters. Polishing media is only meant to trap fines.
    You can add photos in photobucket and copy paste the image file here.
    Post edited by HDCu at 2014-03-28 04:06:42 pm

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership